أسئلة شائعة حول نقاط البيع
لماذا تظهر طريقة الدفع الآجل في شاشة الدفع رغم تفعيل خيار إخفائها من الإعدادات؟
عند تفعيل خيار "إخفاء طريقة الدفع الآجل الافتراضية للنظام" من إعدادات نقاط البيع، يُتوقع ألا تظهر طريقة الدفع الآجل في شاشة الدفع.
- المشكلة:
رغم تفعيل هذا الخيار، تستمر طريقة الدفع الآجل في الظهور في شاشة الدفع.
- السبب:
هذا السلوك يحدث إذا كانت صلاحية "إمكانية الدفع الآجل" مفعّلة للمستخدم في صلاحيات نقاط البيع.
- الحل:
قم بإلغاء تفعيل الصلاحية التالية من إعدادات صلاحيات نقاط البيع للمستخدم:
- اسم الصلاحية: إمكانية الدفع الآجل
بذلك يتم احترام إعداد إخفاء الدفع الآجل، ولن تظهر الطريقة في شاشة الدفع.
س: عند إغلاق الوردية ظهر خطأ "طريقة الدفع مدى مكرر على أكثر من سطر"، ما سبب ذلك؟ وكيف يمكن حله؟
ج: السبب في ظهور هذا الخطأ هو أن طريقة الدفع (مثل "مدى") تم تعديل خصائصها بعد استخدامها في حركات فعلية، تحديدًا تم تغيير خاصية 'طريقة نقدي'
في تعريف طريقة الدفع. نتيجة لذلك، ظهرت نفس طريقة الدفع في أكثر من سطر عند إغلاق الوردية: مرة كطريقة نقدية، ومرة كطريقة غير نقدية (مثل بنكية أو آجلة)، مما سبب تكرارًا غير مسموح به.
الحل: لحل هذه المشكلة، استخدم الأداة البرمجية التالية داخل نظام نقاط البيع:
com.namasoft.pos.util.plugnplay.POSPaymentMethodToggledCashProperty
مرر إليها كود طريقة الدفع التي حدث بها التغيير.
Tips
- لمزيد من التفاصيل حول تشغيل الأدوات البرمجية داخل نقاط البيع، راجع القسم الخاص بها في دليل استعمال النقاط الفنية في نقاط البيع
- النص الأصلي لرسالة الخطأ:
Payment method {0} repeated in multi line